Knowledgebase
ThinLinX Support > ThinLinX Help Desk > Knowledgebase

Search help:


Known issue with TMS on Ubuntu >= 16.04

Solution

Ubuntu disabled SSLv3 at the OpenSSL library level starting from the 16.04 (Xenial) release.  Unfortunately TMS (<= 8.0.0) still uses SSLv3 for (non-HTTPS) data exchanges with tms_client.  Consequently, the only way to get TMS to work on Ubuntu Xenial and later is to downgrade OpenSSL packages to the Wily (15.10) level as follows:

apt-get install zlib1g-dev
wget http://old-releases.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.2d-0ubuntu1.5_amd64.deb
wget http://old-releases.ubuntu.com/ubuntu/pool/main/o/openssl/libssl-dev_1.0.2d-0ubuntu1.5_amd64.deb
wget http://old-releases.ubuntu.com/ubuntu/pool/main/o/openssl/openssl_1.0.2d-0ubuntu1.5_amd64.deb
dpkg -i libssl1.0.0_1.0.2d-0ubuntu1.5_amd64.deb libssl-dev_1.0.2d-0ubuntu1.5_amd64.deb openssl_1.0.2d-0ubuntu1.5_amd64.deb
echo -e 'libssl1.0.0 hold\nlibssl-dev hold\nopenssl hold' | dpkg --set-selections

(installation of zlib1g-dev and downgrade of libssl-dev can be omitted if libssl-dev is not already installed and you do not require it)

In future we will rework TMS and tms_client to use TLS >= 1.1, but this will result in a break in backward compatibility that we expect will cause a great deal of user confusion.

 

 
Was this article helpful? yes / no
Article details
Article ID: 6
Category: Knowledgebase
Date added: 2017-12-08 22:25:22
Views: 236
Rating (Votes): Article not rated yet (0)

 
« Go back